summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-02 01:02:12 -0400
committerMark H Weaver <mhw@netris.org>2015-04-02 01:42:46 -0400
commitb7178dc45d21081ef38795ee2179404a02ac0b2e (patch)
tree1cac5ef096b76f1837d27ee24f57785d8b768a6d /gnu/packages/gnuzilla.scm
parent5fd5e83da60626650c2c3136a4913b0401a446e9 (diff)
downloadguix-b7178dc45d21081ef38795ee2179404a02ac0b2e.tar.gz
gnu: icecat: Apply fixes for CVE-2015-{0801,0807,0815,0816}.
Actually, CVE-2015-0801 and CVE-2015-0816 were already patched in
4c153a9125fa0913077b06b5ed537958ae4ca163, but the corresponding CVEs
were not yet announced.

* gnu/packages/patches/icecat-bug-1146339.patch: Rename to ...
* gnu/packages/patches/icecat-CVE-2015-0801.patch: ... this.
* gnu/packages/patches/icecat-bug-1144991.patch: Rename to ...
* gnu/packages/patches/icecat-CVE-2015-0816.patch: ... this.
* gnu/packages/patches/icecat-CVE-2015-0807.patch,
  gnu/packages/patches/icecat-CVE-2015-0815-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-0815-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-0815-pt3.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them, and adapt to renamed files.
* gnu/packages/gnuzilla.scm (icecat): Add patches, and adapt to renamed files.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 1e9deb8bff..f4a68fb186 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -225,13 +225,17 @@ standards.")
       (sha256
        (base32
         "1rr4axghaypdkrf60i1qp6dz4cd29ya02fs3vyffvp4x9kgcq2dd"))
-      (patches (map search-patch '("icecat-bug-1127780.patch"
+      (patches (map search-patch '("icecat-CVE-2015-0815-pt1.patch"
+                                   "icecat-CVE-2015-0815-pt2.patch"
+                                   "icecat-bug-1127780.patch"
+                                   "icecat-CVE-2015-0807.patch"
+                                   "icecat-CVE-2015-0815-pt3.patch"
                                    "icecat-CVE-2015-0817.patch"
-                                   "icecat-bug-1144991.patch"
+                                   "icecat-CVE-2015-0816.patch"
                                    "icecat-CVE-2015-0818-pt1.patch"
                                    "icecat-bug-1145870.patch"
                                    "icecat-CVE-2015-0818-pt2.patch"
-                                   "icecat-bug-1146339.patch")))))
+                                   "icecat-CVE-2015-0801.patch")))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)