summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-26 16:14:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-04 14:53:25 +0200
commit9b709e332e68995fb1dda6893f4d86f50de27ab2 (patch)
tree25b355bab9dd67e845013e990116a35af4611c50 /gnu/packages/gnuzilla.scm
parent06f4dc2bf62a0fea7577bf917aa3a4cb6ca6b182 (diff)
downloadguix-9b709e332e68995fb1dda6893f4d86f50de27ab2.tar.gz
gnu: mozjs-60: Add support for riscv64-linux.
* gnu/packages/gnuzilla.scm (mozjs-60)[source]: Add patch.
[arguments]: Add phase to update config scripts.
[inputs]: Add config.
* gnu/packages/patches/mozjs60-riscv64-support.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 1ee5248ced..d5d11b59d1 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -364,7 +364,8 @@ in C/C++.")
               (file-name (git-file-name "mozjs" version))
               (sha256
                (base32
-                "1xl6avsj9gkgma71p56jzs7nasc767k3n1frnmri5pad4rj94bij"))))
+                "1xl6avsj9gkgma71p56jzs7nasc767k3n1frnmri5pad4rj94bij"))
+              (patches (search-patches "mozjs60-riscv64-support.patch"))))
     (arguments
      `(#:tests? #f ; FIXME: all tests pass, but then the check phase fails anyway.
        #:test-target "check-jstests"
@@ -419,6 +420,14 @@ in C/C++.")
                       (cons (string-append "--prefix=" out)
                             configure-flags))
                #t)))
+         (add-after 'unpack 'update-config-scripts
+           (lambda* (#:key native-inputs inputs #:allow-other-keys)
+             (for-each (lambda (file)
+                             (install-file
+                               (search-input-file
+                                 (or native-inputs inputs)
+                                 (string-append "/bin/" file)) "build/autoconf"))
+                           '("config.guess" "config.sub"))))
          (add-after 'unpack 'disable-broken-tests
            (lambda _
              ;; This test assumes that /bin exists and contains certain
@@ -428,6 +437,7 @@ in C/C++.")
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
+       ("config" ,config)
        ("which" ,which)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)