summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-03 16:04:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-03 16:04:40 +0200
commit8ecdef3cbbf10ce93634eed3f759891afa7e7b6c (patch)
treec743958179d3acd993ffcef6d723c488e18a187d /gnu/packages/gnuzilla.scm
parentd05e3b08ea0ca6dde6b2a27de5c1bba9cd60e132 (diff)
downloadguix-8ecdef3cbbf10ce93634eed3f759891afa7e7b6c.tar.gz
gnu: IceCat: Remove obsolete phase.
* gnu/packages/gnuzilla.scm (icecat)[arguments]: Remove phase
'augment-CPLUS_INCLUDE_PATH'.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm14
1 files changed, 0 insertions, 14 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 23f15906c5..2db4697a6d 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1016,20 +1016,6 @@ from forcing GEXP-PROMISE."
                   (string-append name "\"" null-hash "\"")))
                (generate-all-checksums "third_party/rust"))
              #t))
-         (add-before 'configure 'augment-CPLUS_INCLUDE_PATH
-           (lambda* (#:key build inputs #:allow-other-keys)
-             ;; Here, we add additional entries to CPLUS_INCLUDE_PATH, to work
-             ;; around a problem that otherwise occurs when attempting to
-             ;; build Stylo, which requires Rust and Clang.  Without these
-             ;; additional entries, errors occur during the build indicating
-             ;; that the <cstddef> and "c++config.h" headers cannot be found.
-             ;; Note that the 'build' keyword argument contains the GNU
-             ;; triplet, e.g. "x86_64-unknown-linux-gnu".
-             (let ((gcc (assoc-ref inputs "gcc")))
-               (setenv "CPLUS_INCLUDE_PATH"
-                       (string-append gcc "/include/c++" ":"
-                                      gcc "/include/c++/" build)))
-             #t))
          (replace 'configure
            ;; configure does not work followed by both "SHELL=..." and
            ;; "CONFIG_SHELL=..."; set environment variables instead