summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:33:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:36:58 +0100
commit110644260c9522f050e214ca575914c89e0b16d6 (patch)
tree1559b81e4be49bc7db4046e3de234c7e792468e0 /gnu/packages/golang-web.scm
parent7a8126e107999b2af4a50bd2ff7e8f1a9faaedab (diff)
downloadguix-110644260c9522f050e214ca575914c89e0b16d6.tar.gz
gnu: go-github-com-emersion-go-mbox: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-mbox): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: Ib367bdb08a6989c73eb00c92b830af8e7b47a1b8
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3c196ef228..7266d3bd28 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -822,6 +822,30 @@ used to build IMAP clients and servers.")
      "This package provides an interface to mailboxes in the Maildir format.")
     (license license:expat)))
 
+(define-public go-github-com-emersion-go-mbox
+  (package
+    (name "go-github-com-emersion-go-mbox")
+    (version "1.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emersion/go-mbox")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vnadh2khx7sxn0irrd8gz8ra02x7ij0q8zglq3rqffqil06nliv"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/emersion/go-mbox"))
+    (home-page "https://github.com/emersion/go-mbox")
+    (synopsis "Go library for handling @code{mbox} files")
+    (description
+     "This package provides a library for parsing and formatting @code{mbox}
+files.")
+    (license license:expat)))
+
 (define-public go-github-com-emersion-go-message
   (package
     (name "go-github-com-emersion-go-message")