summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 22:44:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:51 +0100
commit23c29d662b1f4e9c8503e1c3c822e9971dc41293 (patch)
tree699b136cfb236cb25717c6b0927aa25d03237fe4 /gnu/packages/golang-web.scm
parenta477fece1245bc5042bc3c39483a53d4f8c0d806 (diff)
downloadguix-23c29d662b1f4e9c8503e1c3c822e9971dc41293.tar.gz
gnu: go-github-com-sourcegraph-jsonrpc2: Update to 0.2.0.
* gnu/packages/golang-web.scm (go-github-com-sourcegraph-jsonrpc2): Update to 0.2.0.
[propagated-inputs]: Remove go-github-com-daviddengcn-go-colortext and
go-github-com-motemen-go-colorine.

Change-Id: I8c46e08c6f5d837cd213c157b08fe4a2fd1d320b
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 59453dfe44..275a19617c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2738,7 +2738,7 @@ support.")
 (define-public go-github-com-sourcegraph-jsonrpc2
   (package
     (name "go-github-com-sourcegraph-jsonrpc2")
-    (version "0.1.0")
+    (version "0.2.0")
     (home-page "https://github.com/sourcegraph/jsonrpc2")
     (source
      (origin
@@ -2748,14 +2748,12 @@ support.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+        (base32 "1id35b4mhif9gy1b70mv0x7xkmpm2p8xydix8six10yjyhvm1wjh"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/sourcegraph/jsonrpc2"))
     (propagated-inputs
-     (list go-github-com-daviddengcn-go-colortext
-           go-github-com-gorilla-websocket
-           go-github-com-motemen-go-colorine))
+     (list go-github-com-gorilla-websocket))
     (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
     (description
      "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")