summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:16:23 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:20:06 +0100
commitb4a689bcfb8a062786e415ae71233c52fdbffa79 (patch)
treeebc7d3138819e7c183551dc33d75e44d07d5d6f6 /gnu/packages/golang-web.scm
parent9e1099af3e7861342a382df3be9e1154f075f832 (diff)
downloadguix-b4a689bcfb8a062786e415ae71233c52fdbffa79.tar.gz
gnu: Add go-github-com-whyrusleeping-multiaddr-filter.
* gnu/packages/golang-xyz.scm (go-github-com-whyrusleeping-multiaddr-filter): New variable.

Change-Id: I4e1319bcb6bc6e0b922e72da31697460fbab8622
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e64f20801c..cfb58ce115 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2873,6 +2873,33 @@ replacement for native @code{net/http} module.")
 @command{map[string]interface{}}.")
       (license license:expat))))
 
+(define-public go-github-com-whyrusleeping-multiaddr-filter
+  (package
+    (name "go-github-com-whyrusleeping-multiaddr-filter")
+    (version "0.0.0-20160516205228-e903e4adabd7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/whyrusleeping/multiaddr-filter")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ksd8vnp207dvphmhrazwldj8if900fnyc1pqa9pfvj04qp92640"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      ;; (*testing.common).Fatalf format %s has arg val of wrong type bool
+      #:tests? #f
+      #:import-path "github.com/whyrusleeping/multiaddr-filter"))
+    (home-page "https://github.com/whyrusleeping/multiaddr-filter")
+    (synopsis "Parsing ip filters and masks in the multiaddr format")
+    (description
+     "This module creates very simple
+@url{https://github.com/jbenet/go-multiaddr,multiaddr} formatted cidr
+netmasks.")
+    (license license:expat)))
+
 (define-public go-github-com-xeipuuv-gojsonpointer
   (let ((commit "4e3ac2762d5f479393488629ee9370b50873b3a6")
         (revision "0"))