summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 16:30:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commitc8e9ee9c47690327ea8cde92bb6109eaf33a5fcb (patch)
treeb26676b3dad366bad492adc2c7eb9937afabccd2 /gnu/packages/golang-web.scm
parent44396204d6e7bec4df71a4307336ef161c1a0cce (diff)
downloadguix-c8e9ee9c47690327ea8cde92bb6109eaf33a5fcb.tar.gz
gnu: Add go-github-com-munnerz-goautoneg.
* gnu/packages/golang-web.scm (go-github-com-munnerz-goautoneg): New
variable.

Change-Id: I0e5827d19f49d8c45b2ae6e4ac7300742cf053cf
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 237823e26e..b12018bd34 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1897,6 +1897,30 @@ multistream-select protocol.  The protocol is defined at
 @url{https://github.com/multiformats/multistream-select}")
     (license license:expat)))
 
+(define-public go-github-com-munnerz-goautoneg
+  (package
+    (name "go-github-com-munnerz-goautoneg")
+    (version "0.0.0-20191010083416-a7dc8b61c822")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/munnerz/goautoneg")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m4v6bw6yf1g0kvpc46isjp0qfhx2y8gnvlnyjf637jy64613mgg"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/munnerz/goautoneg"))
+    (home-page "https://github.com/munnerz/goautoneg")
+    (synopsis "HTTP Content-Type Autonegotiation")
+    (description
+     "This package implements @url{https://rfc-editor.org/rfc/rfc2616.html,RFC
+2616} HTTP/1.1 standard.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-nwidger-jsoncolor
   (package
     (name "go-github-com-nwidger-jsoncolor")