summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-12 13:32:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-12 13:32:19 +0100
commitde2845d0c48133056c7901a1bd0e6af86842cf54 (patch)
tree47e38633830954ae59250e5742fb6c10fc5db215 /gnu/packages/golang-web.scm
parentd95b9a080a38518c18dee2554222d05d0cfc6491 (diff)
downloadguix-de2845d0c48133056c7901a1bd0e6af86842cf54.tar.gz
gnu: go-golang-zx2c4-com-wireguard: Move to golang-web.
* gnu/packages/golang.scm (go-golang-zx2c4-com-wireguard): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: Ie0b2a32300436cacd37652996a693bdda85f2cbc
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5c1ece7389..21ba0c3f85 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Filip Lajszczak <filip@lajszczak.dev>
 ;;; Copyright © 2023 Fries <fries1234@protonmail.com>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
@@ -3647,6 +3648,39 @@ programming language, which supports draft-04, draft-06 and draft-07.")
  spec in Go.")
     (license license:bsd-3)))
 
+(define-public go-golang-zx2c4-com-wireguard
+  (package
+    (name "go-golang-zx2c4-com-wireguard")
+    (version "0.0.0-20231211153847-12269c276173")
+    (source
+     (origin
+       (method git-fetch)
+       ;; NOTE: module URL is a redirect
+       ;; target: git.zx2c4.com/wireguard-go
+       ;; source: golang.zx2c4.com/wireguard
+       (uri (git-reference
+             (url "https://git.zx2c4.com/wireguard-go/")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fbc6m0ahifhrd6jdrpdxi8l3b2slpp8fmv20kpq2yzz19vzzgkf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      ;; XXX: Failed on newer version of Golang, the recent release requires
+      ;; gvisor.dev/gvisor, which is huge to pack.
+      #:tests? #f
+      #:import-path "golang.zx2c4.com/wireguard"))
+    (propagated-inputs
+     (list go-golang-org-x-crypto
+           go-golang-org-x-net
+           go-golang-org-x-sys
+           go-golang-org-x-text))
+    (home-page "https://git.zx2c4.com/wireguard")
+    (synopsis "Implementation of WireGuard in Go")
+    (description "This package is a Go Implementation of WireGuard.")
+    (license license:expat)))
+
 ;; XXX: This repository has been archived by the owner on Feb 27, 2023. It is
 ;; now read-only and it is DEPRECATED.
 (define-public go-gopkg-in-square-go-jose-v2