summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorJean SIMARD <woshilapin@tuziwo.info>2024-07-27 23:13:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 21:48:28 +0100
commit22b617992b8b1d0ffedb0b4d8c24800e4aab1f09 (patch)
tree313da0e7bcc21ce2879a9fe5528ee06430019874 /gnu/packages/golang-xyz.scm
parent1d4b72006e3704c954c8f3ccaaae37db5ff4000e (diff)
downloadguix-22b617992b8b1d0ffedb0b4d8c24800e4aab1f09.tar.gz
gnu: Add go-github-com-teambition-rrule-go.
* gnu/packages/golang-xyz.scm (go-github-com-teambition-rrule-go): New
variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I93ea767548d00dd95a570baa358a0a36c81a44bc
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 13472e529c..b2db051f10 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4981,6 +4981,31 @@ well as a program to generate applications and command files.")
 storage system.")
     (license license:bsd-2)))
 
+(define-public go-github-com-teambition-rrule-go
+  (package
+    (name "go-github-com-teambition-rrule-go")
+    (version "1.8.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/teambition/rrule-go")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fnbava35w9z60carny5b7whd4nkv6hrf9g43wwg8d88gfij9zj2"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/teambition/rrule-go"))
+    (home-page "https://github.com/teambition/rrule-go")
+    (synopsis "Recurrence rules for calendar dates for Golang")
+    (description
+     "This package provides a functionality to work with recurrence rules for
+calendar dates.  It offers a complete implementation of the
+@url{https://www.ietf.org/rfc/rfc2445.txt,RFC 2445} specification.")
+    (license license:expat)))
+
 (define-public go-github-com-thejerf-suture
   (package
     (name "go-github-com-thejerf-suture")