summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 22:46:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commit27eecaac18859f08459e45a857947dd8414a8189 (patch)
tree0b245a0709de632a804b806fc54b39a965709e61 /gnu/packages/golang-xyz.scm
parent838377c4d7e587e4e70bcdf85ca663bd149f6a06 (diff)
downloadguix-27eecaac18859f08459e45a857947dd8414a8189.tar.gz
gnu: Add go-k8s-io-klog-v2.
* gnu/packages/golang-xyz.scm (go-k8s-io-klog-v2): New variable.

Change-Id: I98900fdd7449b4e6bf6d4ea35eac659b188182a4
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 34b2c694cd..040b1787b4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6747,6 +6747,25 @@ also provides V-style logging controlled by the @code{-v} and
 @code{https://github.com/golang/glog}.")
     (license license:asl2.0)))
 
+(define-public go-k8s-io-klog-v2
+  (package
+    (inherit go-k8s-io-klog)
+    (name "go-k8s-io-klog-v2")
+    (version "2.130.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kubernetes/klog")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "12q9jhxfpq75sgmdxgcz85znbgdi04ic9zy3rm0c47n24clz6z73"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "k8s.io/klog/v2"))))
+
 (define-public go-mvdan-cc-editorconfig
   (package
     (name "go-mvdan-cc-editorconfig")