summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 10:56:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit4dcc9df560e824eca6a26c0943f3c18a84fa23d0 (patch)
tree70d926c207f124515f7350e30c8845cfe725cb58 /gnu/packages/golang-xyz.scm
parent0f652cc404c6c2dffd86b0582bf9bf1fdab8ce38 (diff)
downloadguix-4dcc9df560e824eca6a26c0943f3c18a84fa23d0.tar.gz
gnu: go-github-com-spf13-cobra: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-spf13-cobra): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I545b0279c040be0412cbca744e949f31e9d34b1f
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 06942a3647..466f13631c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
 ;;; Copyright © 2023 Fries <fries1234@protonmail.com>
@@ -2576,6 +2577,32 @@ Use waterutil with it to work with TUN/TAP packets/frames.")
      "@{gitconfig} is a package to get configuration values from gitconfig.")
     (license license:expat)))
 
+(define-public go-github-com-spf13-cobra
+  (package
+    (name "go-github-com-spf13-cobra")
+    (version "1.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/spf13/cobra")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0mhnqfgcwwcknlhk7n07i02q3iqq6ihksj4dwz296zci8ry3w0d0"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/spf13/cobra"))
+    (propagated-inputs
+     (list go-github-com-spf13-pflag))
+    (home-page "https://github.com/spf13/cobra")
+    (synopsis "Go library for creating CLI applications")
+    (description
+     "Cobra is both a library for creating powerful modern CLI applications as
+well as a program to generate applications and command files.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-stathat-go
   (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
         (revision "0"))