summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 00:08:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:51 +0100
commit54f52ae1363ddc8c60051a678f941cc0c00b9877 (patch)
treec143eff3a4e9b051600281f9235b6a3e39c588a6 /gnu/packages/golang-xyz.scm
parenta60fd377622f76e4a4d9f728624956c5d0d9e59d (diff)
downloadguix-54f52ae1363ddc8c60051a678f941cc0c00b9877.tar.gz
gnu: Add go-github-com-aymanbagabas-go-osc52-v2.
* gnu/packages/golang-xyz.scm (go-github-com-aymanbagabas-go-osc52-v2):
New variable.

Change-Id: I6a6bcfb2edce1e062034bd84648c1f4c563c560f
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bd4f7da876..9a85f7399d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -820,6 +820,30 @@ for generating command line clients for your application configuration that is
 stored in a Go struct.")
     (license license:mpl2.0)))
 
+(define-public go-github-com-aymanbagabas-go-osc52-v2
+  (package
+    (name "go-github-com-aymanbagabas-go-osc52-v2")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aymanbagabas/go-osc52")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y4y49zys7fi5wpicpdmjqnk0mb6569zg546km02yck2349jl538"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/aymanbagabas/go-osc52/v2"))
+    (home-page "https://github.com/aymanbagabas/go-osc52")
+    (synopsis "Terminal ANSI OSC52 wrapper")
+    (description
+     "OSC52 is a terminal escape sequence that allows copying text to the
+clipboard.")
+    (license license:expat)))
+
 (define-public go-github-com-benbjohnson-clock
   (package
     (name "go-github-com-benbjohnson-clock")