summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 17:04:24 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commit76f1290a388a7f525458b0f37a9e14aa396f302d (patch)
tree30e964a315ecff82f6dd243db6d6e4957023a3fa /gnu/packages/golang-xyz.scm
parentfbdf5b76a70c28dcaa80f81b569b5bf21560d374 (diff)
downloadguix-76f1290a388a7f525458b0f37a9e14aa396f302d.tar.gz
gnu: Add go-github-com-go-kit-log.
* gnu/packages/golang-xyz.scm (go-github-com-go-kit-log): New variable.

Change-Id: Icc42de8b129ea3c9e69eaa77e1d5e6f838b460ec
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3e248a571a..82b9fa59d5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2017,6 +2017,34 @@ Differentiation between text and binary files}.
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-go-kit-log
+  (package
+    (name "go-github-com-go-kit-log")
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/go-kit/log")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xjv2g1cd1iaghhm1c1zw0lcz89a9zq5xradyjipvrbqxbxckqm6"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/go-kit/log"))
+    (propagated-inputs
+     (list go-github-com-go-logfmt-logfmt))
+    (home-page "https://github.com/go-kit/log")
+    (synopsis "Minimal and extensible structured logger")
+    (description
+     "This package provides a minimal interface for structured logging in
+services.  It may be wrapped to encode conventions, enforce type-safety,
+provide leveled logging, and so on.  It can be used for both typical
+application log events, and log-structured data streams.")
+    (license license:expat)))
+
 (define-public go-github-com-go-logfmt-logfmt
   (package
     (name "go-github-com-go-logfmt-logfmt")