summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-11 22:23:15 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 22:01:36 +0100
commitbee20255f7e20b7b79217abfe755f5ea1fc6d993 (patch)
tree88593c29efe13b7b95a623f183cc0b7f5d291f00 /gnu/packages/golang-xyz.scm
parent58405cbe3abef0a511bba32cf321981766f1b231 (diff)
downloadguix-bee20255f7e20b7b79217abfe755f5ea1fc6d993.tar.gz
gnu: Add go-github-com-liyue201-gostl.
* gnu/packages/golang-xyz.scm (go-github-com-liyue201-gostl): New variable.

Change-Id: I6abdb2f1ca4bd5e53c2b5a72214dcd5b34cbf20d
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 037cef32db..40fc2ce5f7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4251,6 +4251,40 @@ allocator.  This is primarily useful for long lived buffers that usually sit emp
 length-delimited slices.  It's helpful for building wire protocols.")
     (license license:expat)))
 
+(define-public go-github-com-liyue201-gostl
+  (package
+    (name "go-github-com-liyue201-gostl")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/liyue201/gostl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1dxzh791agir21dp1jmfa1bvqc23byz93fx3jlm94brlgm9zdkd3"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/liyue201/gostl"
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/liyue201/gostl")
+    (synopsis "Data structure and algorithm library for Go")
+    (description
+     "@code{gostl} is a data structure and algorithm library for Go, designed
+to provide functions similar to C++ STL.")
+    (license license:expat)))
+
 (define-public go-github-com-logrusorgru-aurora
   (package
     (name "go-github-com-logrusorgru-aurora")