summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 13:21:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 14:37:29 +0100
commitd4fdac60bf0237c3eea10c8f2bf60e85fe74217d (patch)
tree80dc24cd4c6dba1bb3e045eae1299bfb2973c78d /gnu/packages/golang-xyz.scm
parent69b0178ba62cd4c2de2aa87d292cf4c7f465a3a0 (diff)
downloadguix-d4fdac60bf0237c3eea10c8f2bf60e85fe74217d.tar.gz
gnu: go-github-com-syndtr-goleveldb-leveldb: Rename variable.
* gnu/packages/golang-xyz.scm (go-github-com-syndtr-goleveldb-leveldb):
Rename variable to go-github-com-syndtr-goleveldb to reflect go.mode
name.
[arguments]: <#:import-path>: Adjust it to reflect go.mode import
path. <#:phases>: Delete 'build phase; use custom 'check phase.
* gnu/packages/ipfs.scm (kubo) [inputs]: Remove
go-github-com-syndtr-goleveldb-leveldb. Add go-github-com-syndtr-goleveldb
* gnu/packages/mail.scm: Likewise.

Change-Id: I84c6a2b398adc7230494847215ccbd1cde73afc9
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fbe5921e25..66ec8ae39f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4470,9 +4470,9 @@ well as a program to generate applications and command files.")
       (home-page "https://github.com/stathat/go")
       (license license:expat))))
 
-(define-public go-github-com-syndtr-goleveldb-leveldb
+(define-public go-github-com-syndtr-goleveldb
   (package
-    (name "go-github-com-syndtr-goleveldb-leveldb")
+    (name "go-github-com-syndtr-goleveldb")
     (version "1.0.0")
     (source
      (origin
@@ -4487,8 +4487,16 @@ well as a program to generate applications and command files.")
     (arguments
      (list
       #:go go-1.21
-      #:import-path "github.com/syndtr/goleveldb/leveldb"
-      #:unpack-path "github.com/syndtr/goleveldb"))
+      #:import-path "github.com/syndtr/goleveldb"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Replace when go-build-system supports nested path.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key import-path tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
     (propagated-inputs
      (list go-github-com-onsi-gomega
            go-github-com-onsi-ginkgo