summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 00:13:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 01:05:17 +0100
commitd650834c63cf3bbade064262f78acb0fc5c72259 (patch)
treeade21768dd30c39a1a301e85c87002f7728fa4ed /gnu/packages/golang-xyz.scm
parent982bb6d468fa5400a131b363eedc1a6e6e72608b (diff)
downloadguix-d650834c63cf3bbade064262f78acb0fc5c72259.tar.gz
gnu: Add go-git-sr-ht-rockorager-vaxis.
* gnu/packages/golang-xyz.scm (go-git-sr-ht-rockorager-vaxis): New variable.

Change-Id: I7f8815d9c840f204ea9f7cec3a8c73175f096f31
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9f526368c8..24cf0ec329 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -321,6 +321,42 @@ annotations on struct fields.  It came as a spin-off from
 commands.")
     (license license:expat)))
 
+(define-public go-git-sr-ht-rockorager-vaxis
+  (package
+    (name "go-git-sr-ht-rockorager-vaxis")
+    (version "0.9.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~rockorager/vaxis")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pmi4bigqgrfdlk9d6ia3jxgcr4iadiyynf6bny9fdc3yyppcxic"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "git.sr.ht/~rockorager/vaxis"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (propagated-inputs
+     (list go-github-com-containerd-console
+           go-github-com-creack-pty
+           go-github-com-mattn-go-runewidth
+           go-github-com-mattn-go-sixel
+           go-github-com-rivo-uniseg
+           go-golang-org-x-exp
+           go-golang-org-x-image
+           go-golang-org-x-sys))
+    (home-page "https://git.sr.ht/~rockorager/vaxis")
+    (synopsis "TUI library for Golang")
+    (description
+     "Package vaxis is a terminal user interface for modern terminals.  It
+supports supports modern terminal features, such as styled underlines and
+graphics.  A widgets package is provided with some useful widgets.")
+    (license license:asl2.0)))
+
 (define-public go-git-sr-ht-sircmpwn-getopt
   (package
     (name "go-git-sr-ht-sircmpwn-getopt")