summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:33:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:33:34 +0100
commite799307decc7187352fb21c4d78b312c66e9aa78 (patch)
tree69a72605f606bde0ae246b9ab7d3bc107c85cc1b /gnu/packages/golang-xyz.scm
parent63392aa2ff8a1c991ed20f4043f08df53c76002f (diff)
downloadguix-e799307decc7187352fb21c4d78b312c66e9aa78.tar.gz
gnu: go-github-com-goccy-go-yaml: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-goccy-go-yaml): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I44dc5b01079c6486c31f440c8a1f506a419a0f38
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1bfeece415..56b4ae9a65 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2018,6 +2018,51 @@ the library more lightweight.")
      "This package provides a Go implementation of globs.")
     (license license:expat)))
 
+(define-public go-github-com-goccy-go-yaml
+  (package
+    (name "go-github-com-goccy-go-yaml")
+    (version "1.11.3")
+    (home-page "https://github.com/goccy/go-yaml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1rm2rfnlvv704zkb1mnjqv5xx32vfkzv7r2kc8if6gr9ryb7hmbf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.18
+      #:import-path "github.com/goccy/go-yaml"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-benchmarks
+            (lambda* (#:key import-path #:allow-other-keys)
+              (delete-file-recursively
+               (string-append "src/" import-path "/benchmarks")))))))
+    (native-inputs
+     (list go-github-com-go-playground-validator-v10
+           go-github-com-google-go-cmp-cmp))
+    (propagated-inputs
+     (list go-github-com-fatih-color
+           go-golang-org-x-xerrors))
+    (synopsis "YAML support for the Go language")
+    (description
+     "This package provides features beyond the
+@uref{https://github.com/go-yaml/yaml, defacto YAML library} including:
+
+@itemize
+@item Pretty format for error notifications
+@item Support Scanner or Lexer or Parser as public API
+@item Support Anchor and Alias to Marshaler
+@item Allow referencing elements declared in another file via anchors
+@item Extract value or AST by YAMLPath (YAMLPath is like a JSONPath)
+@end itemize")
+    (license license:expat)))
+
 (define-public go-github-com-gookit-color
   (package
     (name "go-github-com-gookit-color")