summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:45:01 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:54 +0100
commita62ed0b3bf7a0ce87da8545627c09a0ca5d5ad8e (patch)
tree1e10d3b99fcaf9b9f46d346a4caa861fbfc3f075 /gnu/packages/golang.scm
parent068a3709dc45264145e5e82c87d569a2ba5f1354 (diff)
downloadguix-a62ed0b3bf7a0ce87da8545627c09a0ca5d5ad8e.tar.gz
gnu: Add go-github-com-google-go-cmdtest.
* gnu/packages/golang.scm (go-github-com-google-go-cmdtest): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 561abf224d..30ca12cb5f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11089,6 +11089,35 @@ production-ready implementation, compatible with the original Jsonnet C++
 implementation.")
     (license license:asl2.0)))
 
+(define-public go-github-com-google-go-cmdtest
+  (let ((commit "55ab3332a786118933ddf71544aae14951ba9bc5")
+        (revision "0"))
+    (package
+      (name "go-github-com-google-go-cmdtest")
+      (version (git-version "0.4.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/google/go-cmdtest")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10kswvbdwissjb5mr0ys4b3ppxkxlpklqg7cr2z7rv21g2vwczbl"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/google/go-cmdtest"))
+      (propagated-inputs (list go-github-com-google-renameio
+                               go-github-com-google-go-cmp-cmp))
+      (home-page "https://github.com/google/go-cmdtest")
+      (synopsis "Testing for your CLI")
+      (description
+       "The cmdtest package simplifies testing of command-line interfaces.  It
+provides a simple, cross-platform, shell-like language to express command
+execution.  It can compare actual output with the expected output, and can
+also update a file with new \"golden\" output that is deemed correct.")
+      (license license:asl2.0))))
+
 (define-public go-github-com-google-safehtml
   (package
     (name "go-github-com-google-safehtml")