summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:28:55 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:02:56 -0400
commitdc01497850dd1af2378736a018df75a2fd603f22 (patch)
treee64fc0d63e610ce0c18d9713c014c77b3c403eb3 /gnu/packages/golang.scm
parent4cd78484bbb9625d7ffeaa9bad3471e443e921ee (diff)
downloadguix-dc01497850dd1af2378736a018df75a2fd603f22.tar.gz
gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check).
* gnu/packages/golang.scm (go-github-com-stretchr-testify): Move from
here...
* gnu/packages/golang-check.scm: ...to here.

* gnu/packages/databases.scm: Add (gnu packages golang-check) module.
* gnu/packages/education.scm: As above...
* gnu/packages/ipfs.scm: As above...
* gnu/packages/irc.scm: As above...
* gnu/packages/mail.scm: As above...
* gnu/packages/textutils.scm: As above...
* gnu/packages/version-control.scm: As above...

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm37
1 files changed, 1 insertions, 36 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0277265375..9a7f60fc0a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -78,6 +78,7 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages golang-check)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages mail)
   #:use-module (gnu packages mp3)
@@ -4588,42 +4589,6 @@ Go.")
 slices, JSON and other data.")
     (license license:expat)))
 
-(define-public go-github-com-stretchr-testify
-  (package
-    (name "go-github-com-stretchr-testify")
-    (version "1.7.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/stretchr/testify")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/stretchr/testify"))
-    (propagated-inputs
-     `(("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
-       ("github.com/pmezard/go-difflib" ,go-github-com-pmezard-go-difflib)
-       ("github.com/stretchr/objx" ,go-github-com-stretchr-objx)
-       ("gopkg.in/yaml.v3" ,go-gopkg-in-yaml-v3)))
-    (home-page "https://github.com/stretchr/testify")
-    (synopsis "Go helper library for tests and invariant checking")
-    (description "This package provide many tools for testifying that your
-code will behave as you intend.
-
-Features include:
-@itemize
-@item Easy assertions
-@item Mocking
-@item HTTP response trapping
-@item Testing suite interfaces and functions.
-@end itemize")
-    (license license:expat)))
-
 (define go-github-com-stretchr-testify-bootstrap
   (package
     (inherit go-github-com-stretchr-testify)