summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:08:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:50:26 +0000
commitfe43dfb5c3e34ec1064cda889261d93a2d6196d2 (patch)
treee69251611d603310fd25cf74aef9373e8049c047 /gnu/packages/golang.scm
parent791578befb7e129f682f38bfe903c23baa46fb91 (diff)
downloadguix-fe43dfb5c3e34ec1064cda889261d93a2d6196d2.tar.gz
gnu: go-github-com-multiformats-go-multiaddr: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-multiformats-go-multiaddr):
Move from here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I31d9e4babae22a0c9b3bd41ce23bd30c265956cf
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c386421bec..557ffd144f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5176,48 +5176,6 @@ maps, slices, or pointers, and copy their data as well instead of just their
 references.")
     (license license:expat)))
 
-(define-public go-github-com-multiformats-go-multiaddr
-  (let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")
-        (revision "0"))
-    (package
-      (name "go-github-com-multiformats-go-multiaddr")
-      (version (git-version "1.3.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/multiformats/go-multiaddr")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0p5f8h098a4yjjmzsgqs7vhx1iqifb8izwg3559cr4h7clkpzznh"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path
-         "github.com/multiformats/go-multiaddr"))
-      (native-inputs
-       (list go-github-com-multiformats-go-multihash
-             go-github-com-gxed-hashland-keccakpg
-             go-github-com-minio-blake2b-simd
-             go-github-com-minio-sha256-simd
-             go-github-com-mr-tron-base58
-             go-github-com-spaolacci-murmur3
-             go-golang-org-x-crypto))
-      (home-page "https://github.com/multiformats/go-multiaddr")
-      (synopsis "Composable and future-proof network addresses")
-      (description "Multiaddr is a standard way to represent addresses that
-does the following:
-
-@itemize
-@item Support any standard network protocols.
-@item Self-describe (include protocols).
-@item Have a binary packed format.
-@item Have a nice string representation.
-@item Encapsulate well.
-@end itemize\n")
-      (license license:expat))))
-
 (define-public go-github-com-multiformats-go-multiaddr-net
   (let ((commit "1cb9a0e8a6de3c8a10f6cee60d01d793603c4f7e")
         (revision "0"))