summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-02-26 20:13:19 +0100
committerLeo Famulari <leo@famulari.name>2023-02-26 14:29:59 -0500
commit1a550c93e54aa2ba39cd12af5b0348019e315dd4 (patch)
treeffac71e906252e5bc777307b2d63e13abcd942a7 /gnu/packages/golang.scm
parent226103fdd1256ae372250fc95163307e14f34d58 (diff)
downloadguix-1a550c93e54aa2ba39cd12af5b0348019e315dd4.tar.gz
gnu: Add go-golang.org-x-sync-semaphore.
* gnu/packages/golang.scm (go-golang.org-x-sync-semaphore):
  New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c4b6bcd874..7268b661cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -39,6 +39,7 @@
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7409,6 +7410,17 @@ common task.")
       (home-page "https://godoc.org/golang.org/x/sync/errgroup")
       (license license:bsd-3))))
 
+(define-public go-golang.org-x-sync-semaphore
+  (package
+    (inherit go-golang.org-x-sync-errgroup)
+    (name "go-golang.org-x-sync-semaphore")
+    (arguments
+     '(#:import-path "golang.org/x/sync/semaphore"
+       #:unpack-path "golang.org/x/sync"))
+    (synopsis "Weighted semaphore implementation in Go")
+    (description "Weighted semaphore implementation in Go.")
+    (home-page "https://godoc.org/golang.org/x/sync/semaphore")))
+
 (define (go-gotest-tools-source version sha256-base32-hash)
   (origin
     (method git-fetch)