summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 22:07:05 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:30 -0500
commit5d9515d8809ccd1e6d353a218ddf4998b4d3a64b (patch)
treeb0fd0a35a399b7a4ac0e6b15b92ea5a5144d48be /gnu/packages/golang.scm
parent2c0bc073f2a2595489bfe191544466bf8b86d062 (diff)
downloadguix-5d9515d8809ccd1e6d353a218ddf4998b4d3a64b.tar.gz
gnu: go-github-com-urfave-cli: Update to 1.22.2.
* gnu/packages/golang.scm (go-github-com-urfave-cli): Update to 1.22.2.
[propagated-inputs]: Add go-github-com-go-md2man.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b1bd58fea5..071bda4f1a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2469,7 +2469,7 @@ as conversion to and from @command{net.Addr}.")
 (define-public go-github-com-urfave-cli
   (package
     (name "go-github-com-urfave-cli")
-    (version "1.21.0")
+    (version "1.22.2")
     (source
      (origin
        (method git-fetch)
@@ -2479,10 +2479,12 @@ as conversion to and from @command{net.Addr}.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "104jldhxn6d97l5vsbsl0q8hgy1bxrahbr6dbfqrlppva51jmydd"))))
+         "10mcnvi5qmn00vpyk6si8gjka7p654wr9hac4zc9w5h3ickhvbdc"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/urfave/cli"))
+    (propagated-inputs
+     `(("go-github-com-go-md2man" ,go-github-com-go-md2man)))
     (home-page "https://github.com/urfave/cli")
     (synopsis "Simple, fast, and fun package for building command line apps in Go")
     (description "@command{cli} is a simple, fast, and fun package for