summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:42 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:18 -0400
commit6bd07c444309b7a319b27c4c37617b0e6cb6dda9 (patch)
tree4a49e7a150f790f38ed0ef6bc7167d95ebf83ce3 /gnu/packages/golang.scm
parent01c974855598e0a7ead38639d1be73b3244f4ec2 (diff)
downloadguix-6bd07c444309b7a319b27c4c37617b0e6cb6dda9.tar.gz
gnu: Add go-github-com-olekukonko-ts.
* gnu/packages/golang.scm (go-github-com-olekukonko-ts): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c5103b9cc9..a242d598d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9238,6 +9238,31 @@ which produce colorized output using github.com/fatih/color.")
 @end itemize\n")
     (license license:expat)))
 
+(define-public go-github-com-olekukonko-ts
+  (let ((commit "78ecb04241c0121483589a30b0814836a746187d")
+        (revision "0"))
+    (package
+      (name "go-github-com-olekukonko-ts")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/olekukonko/ts")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0k88n5rvs5k5zalbfa7c71jkjb8dhpk83s425z728qn6aq49c978"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/olekukonko/ts"
+         #:tests? #f)) ; inappropriate ioctl for device.
+      (home-page "https://github.com/olekukonko/ts/")
+      (synopsis "Simple Go application to get the size of the terminal")
+      (description "This package provides a simple Go application to get the
+size of the terminal.")
+      (license license:expat))))
+
 (define-public go-github-com-yuin-goldmark
   (package
     (name "go-github-com-yuin-goldmark")