summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:01:08 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commit38d346dcc6ae84bcf17c57989816848051d89028 (patch)
tree0ab80a72f3947bbeb70b0d74dfc3ce349d1eb4de /gnu/packages/golang.scm
parent66fb6e292a5a315a62810031e16ecfe30cb88d7d (diff)
downloadguix-38d346dcc6ae84bcf17c57989816848051d89028.tar.gz
gnu: Add go-github-com-whyrusleeping-tar-utils.
* gnu/packages/golang.scm (go-github-com-whyrusleeping-tar-utils): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index afad3aae44..3b354372c6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3124,3 +3124,28 @@ common functions in stdlib's @command{net} package.  This means wrappers of
 standard net symbols like @command{net.Dial} and @command{net.Listen}, as well
 as conversion to and from @command{net.Addr}.")
       (license license:expat))))
+
+(define-public go-github-com-whyrusleeping-tar-utils
+  (let ((commit "8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc")
+        (revision "0"))
+    (package
+      (name "go-github-com-whyrusleeping-tar-utils")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/whyrusleeping/tar-utils.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "14jjdw3yics0k467xsyk388684wdpi0bbx8nqj0y4pqxa0s0in6s"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path
+         "github.com/whyrusleeping/tar-utils"))
+      (home-page "https://github.com/whyrusleeping/tar-utils")
+      (synopsis "Tar utilities extracted from go-ipfs codebase")
+      (description "Tar utilities extracted from @command{go-ipfs} codebase.")
+      (license license:expat))))