summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 10:59:38 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:21 +0200
commita9010ead4c727e3dfd3ebd04fabcc915d54f799d (patch)
treec031ebaeb6954154781d562eee0678183234a646 /gnu/packages/golang.scm
parent7eb0ad380b655b3d8869ea3aab1c6e33ec2cf669 (diff)
downloadguix-a9010ead4c727e3dfd3ebd04fabcc915d54f799d.tar.gz
gnu: Add go-golang-org-x-crypto-ripemd160.
* gnu/packages/golang.scm (go-golang-org-x-crypto-ripemd160): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2042692a2..66f2b729c5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1002,6 +1002,18 @@ Tiny Encryption Algorithm (XTEA) block cipher.")
     (description "This package provides a Go implementation of the ED25519
 signature algorithm.")))
 
+(define-public go-golang-org-x-crypto-ripemd160
+  (package
+    (inherit go-golang-org-x-crypto-bcrypt)
+    (name "go-golang-org-x-crypto-ripemd160")
+    (arguments
+     (substitute-keyword-arguments (package-arguments go-golang-org-x-crypto-bcrypt)
+       ((#:import-path _)
+        "golang.org/x/crypto/ripemd160")))
+    (synopsis "RIPEMD-160 in Go")
+    (description "This package provides a Go implementation of the RIPEMD-160
+hash algorithm.")))
+
 ;; Go searches for library modules by looking in the GOPATH environment
 ;; variable.  This variable is a list of paths.  However, Go does not
 ;; keep searching on GOPATH if it tries and fails to import a module.