summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 14:16:35 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:20 -0400
commitfad3cce201b857f073a816c4bbe9da5d75e1c5e4 (patch)
tree339d9cf3b7f111a949428a8e00dcd3abac2125b9 /gnu/packages/golang.scm
parentaa6df6d4e1a22456742875cb5775bf3f3d5164b6 (diff)
downloadguix-fad3cce201b857f073a816c4bbe9da5d75e1c5e4.tar.gz
gnu: Add go-github-com-willscott-goturn.
* gnu/packages/golang.scm (go-github-com-willscott-goturn): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5fbe9d0872..5e9c16b9f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,32 @@
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-willscott-goturn
+  (let ((commit "19f41278d0c9251d64e0ee29f37d51e87a24a97b")
+        (revision "0"))
+    (package
+      (name "go-github-com-willscott-goturn")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/willscott/goturn")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zwvhfznr84ayzknn9flh65nvqjsixisgy9fkhz2jlahl1ldqcq7"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/willscott/goturn"))
+      (home-page "https://github.com/willscott/goturn")
+      (synopsis "Go TURN dialer")
+      (description "GoTURN is a library providing a Go interface compatible with
+the golang proxy package which connects through a TURN relay.  It provides
+parsing and encoding support for STUN and TURN protocols.")
+      (license license:bsd-3))))
+
 (define-public go-torproject-org-pluggable-transports-goptlib
   (package
     (name "go-torproject-org-pluggable-transports-goptlib")