summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-03-19 15:45:34 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-20 11:19:29 +0100
commit81976123b2da8609efff9b5dec4baf86bdd0b8fd (patch)
treeb773138e82e7153d7b92e54fe654102c6cc1151a /gnu/packages/golang.scm
parent08c3614125c0ebce9dc61b19fcd3d9d4ca6b6d8f (diff)
downloadguix-81976123b2da8609efff9b5dec4baf86bdd0b8fd.tar.gz
gnu: Add go-golang-org-x-lint.
* gnu/packages/golang.scm (go-golang-org-x-lint): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a3f33678fa..413c491b8d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6916,3 +6916,31 @@ atomic access.")
     (description
      "@code{multierr} allows combining one or more Go errors together.")
     (license license:expat)))
+
+(define-public go-golang-org-x-lint
+  (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
+        (revision "0"))
+    (package
+      (name "go-golang-org-x-lint")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://go.googlesource.com/lint")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0ms3rs5hvpnm9bxbr5f9743i7hn2bbmqdmvzxq6nmi0f24ypv1l3"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "golang.org/x/lint"
+         #:tests? #f)) ;; TODO: Fix tests
+      (propagated-inputs
+       `(("go-golang-org-x-tools" ,go-golang-org-x-tools)))
+      (home-page "https://golang.org/x/lint")
+      (synopsis "Linter for Go source code")
+      (description
+       "This is a linter for Go source code.  Unlike gofmt, it doesn't
+reformat the source code, it only prints out style mistakes.")
+      (license license:bsd-3))))