summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:17 +0100
commitb0801110cc729173a38a159d4a0c2094e5784ef4 (patch)
tree2b7833dd1593297092809306dfe5d5aca398787a /gnu/packages/golang.scm
parentf33ab4713b223d8f4e9040dcc76befddb8b7122a (diff)
downloadguix-b0801110cc729173a38a159d4a0c2094e5784ef4.tar.gz
gnu: lf: Fix build.
* gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2-2.3): New public variable.
* gnu/packages/disk.scm (lf)[native-inputs]: Use it instead of
go-github-com-gdamore-tcell-v2.

Reported by Tyler Wolf <https://issues.guix.gnu.org/59663>.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b7c0acb9f6..70ddef52f1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6259,6 +6259,21 @@ systems.")
        (modify-inputs (package-inputs go-github-com-gdamore-tcell)
          (prepend go-golang-org-x-term go-golang-org-x-sys)))))
 
+(define-public go-github-com-gdamore-tcell-v2-2.3
+  (package
+    (inherit go-github-com-gdamore-tcell-v2)
+    (name "go-github-com-gdamore-tcell")
+    (version "2.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gdamore/tcell")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ypbl5080q9sd3irad8mv7zlg4242i8pmg5xyhbyq95kymwibaid"))))))
+
 (define-public go-git-sr-ht-rockorager-tcell-term
   (package
     (name "go-git-sr-ht-rockorager-tcell-term")