summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-25 14:28:12 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-17 23:04:29 +0000
commited0c6a768ee84fadfc88d3701fbbee982fa033a5 (patch)
tree7419dcda914219eb585dcfcc1a2eed47ff337e2e /gnu/packages/golang.scm
parentc4d2cffae7e8d6420dd7bd1fd19d31ddab89c101 (diff)
downloadguix-ed0c6a768ee84fadfc88d3701fbbee982fa033a5.tar.gz
gnu: Add go-github-com-hashicorp-hcl.
* gnu/packages/golang.scm (go-github-com-hashicorp-hcl): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92e612d34b..e0ce1032f7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -664,3 +664,30 @@ program's help message rather than specifying it programatically with
 command-line parsers.")
     (home-page "https://github.com/tj/docopt")
     (license license:expat)))
+
+(define-public go-github-com-hashicorp-hcl
+  (let ((commit "23c074d0eceb2b8a5bfdbb271ab780cde70f05a8")
+        (revision "0"))
+    (package
+      (name "go-github-com-hashicorp-hcl")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/hashicorp/hcl")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "0db4lpqb5m130rmfy3s3gjjf4dxllypmyrzxv6ggqhkmwmc7w4mc"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:tests? #f
+         #:import-path "github.com/hashicorp/hcl"))
+      (synopsis "Go implementation of HashiCorp Configuration Language")
+      (description
+       "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}.  HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+      (home-page "https://github.com/hashicorp/hcl")
+      (license license:mpl2.0))))