summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-03-19 15:13:12 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-20 11:19:29 +0100
commit3554527c53f02aeafbbf18515fae88430578f27a (patch)
treefd3632525f5c17b91906afebfcdb3a52504c09e5 /gnu/packages/golang.scm
parentefbc8db0f06566cf14aa3127e5bbf2dfae721e6e (diff)
downloadguix-3554527c53f02aeafbbf18515fae88430578f27a.tar.gz
gnu: Add go-github-com-pborman-getopt.
* gnu/packages/golang.scm (go-github-com-pborman-getopt): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 30a36540f4..0d434f8bea 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6841,3 +6841,26 @@ sinks and sources.")
        "This packages provides Cgo bindings to PulseAudio's Simple API, to play
 or capture raw audio.")
       (license license:expat))))
+
+(define-public go-github-com-pborman-getopt
+  (package
+    (name "go-github-com-pborman-getopt")
+    (version "2.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pborman/getopt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sacv6g8cxfibxd3gnfjnzp7fynrnc4s2aaz5wbxivqqhvflc22l"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/pborman/getopt"))
+    (home-page "https://github.com/pborman/getopt")
+    (synopsis "Getopt style option parsing for Go")
+    (description
+     "This package provides traditional getopt processing for implementing
+programs that use traditional command lines.")
+    (license license:bsd-3)))