summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-08-17 08:50:41 +0300
committerArun Isaac <arunisaac@systemreboot.net>2021-08-17 13:50:12 +0530
commit66cb568e311c88891de9c27bcb0f3eb658af6ae3 (patch)
tree9e3dc89df0512bef30f31b142df2069a4919fdc5 /gnu/packages/golang.scm
parentf7094f5a4207a706c9ed9024d71a442f14d0a7fd (diff)
downloadguix-66cb568e311c88891de9c27bcb0f3eb658af6ae3.tar.gz
gnu: Add go-github-com-oneofone-xxhash.
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f4cd30c662..490872e886 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -29,6 +29,7 @@
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8396,3 +8397,27 @@ zero round-trip encryption, and other advanced features.")
     (synopsis "Go compression library")
     (description "@code{compress} provides various compression algorithms.")
     (license license:bsd-3)))
+
+(define-public go-github-com-oneofone-xxhash
+  (package
+    (name "go-github-com-oneofone-xxhash")
+    (version "1.2.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OneOfOne/xxhash")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/OneOfOne/xxhash"))
+    (home-page "https://github.com/OneOfOne/xxhash")
+    (synopsis "Go implementation of xxHash")
+    (description "This is a native Go implementation of the
+@url{https://github.com/Cyan4973/xxHash, xxHash} algorithm, an extremely fast
+non-cryptographic hash algorithm, working at speeds close to RAM limits.")
+    (license license:asl2.0)))