summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-09 12:35:22 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-08-01 19:20:27 +0530
commit7aa2972bfaed8cf2dccfd0d5bc165ca3a36ab907 (patch)
tree65ee4230b2b6045550c9583430ce2a70656149fc /gnu/packages/golang.scm
parentc94683e017a1912ae791b1d5f5d83a712cee6a68 (diff)
downloadguix-7aa2972bfaed8cf2dccfd0d5bc165ca3a36ab907.tar.gz
gnu: Add go-github-com-flynn-noise.
* gnu/packages/golang.scm (go-github-com-flynn-noise): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 673d206713..5a7f27bc91 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8324,3 +8324,31 @@ performance for large inputs and outputs.")
     (description "@code{term} provides support functions for dealing with
 terminals, as commonly found on Unix systems.")
     (license license:bsd-3)))
+
+(define-public go-github-com-flynn-noise
+  (package
+    (name "go-github-com-flynn-noise")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/flynn/noise")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1j6phxyqx06wcqxjpin696fkp85s76qcp3i2f7fv6q2fb6618f6y"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/flynn/noise"))
+    (propagated-inputs
+     `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
+       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+    (home-page "https://github.com/flynn/noise")
+    (synopsis "Go implementation of the Noise protocol framework")
+    (description "@code{noise} implements the Noise protocol framework.  Noise
+is a low-level framework for building crypto protocols.  Noise protocols
+support mutual and optional authentication, identity hiding, forward secrecy,
+zero round-trip encryption, and other advanced features.")
+    (license license:bsd-3)))