summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 02:29:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 15:01:06 +0200
commitc43e1e0f9bc33dfde51c36e131edefe56162b97f (patch)
tree4ed969c0781edcc7a7ce509a45ef515ea4928529 /gnu/packages/golang.scm
parent8dc33b00dbd27cc0dfb8ab2ec253e323948bf7df (diff)
downloadguix-c43e1e0f9bc33dfde51c36e131edefe56162b97f.tar.gz
gnu: Add go-github-com-gizak-termui.
* gnu/packages/golang.scm (go-github-com-gizak-termui): New public variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8247b09ea5..0318918a37 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -65,6 +65,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages terminals)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
@@ -653,6 +654,41 @@ jar struct to manage the cookies added to the cookie jar.")
       (home-page "https://github.com/aki237/nscjar")
       (license license:expat))))
 
+(define-public go-github-com-gizak-termui
+  (package
+    (name "go-github-com-gizak-termui")
+    (version "3.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gizak/termui")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1v3k8l5p95kb1v297ra5mw9sxdd59y82y6ibjzya5ma2pry6k5cn"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:unpack-path "github.com/gizak/termui"
+       #:import-path "github.com/gizak/termui/v3"))
+    (propagated-inputs
+     `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+       ("go-github-com-mitchellh-go-wordwrap"
+        ,go-github-com-mitchellh-go-wordwrap)
+       ("go-github.com-nsf-termbox-go" ,go-github.com-nsf-termbox-go)))
+    (home-page "https://github.com/gizak/termui")
+    (synopsis "Terminal dashboard widget Go library")
+    (description
+     "The termui Go library draws customizable dashboard widgets in a text
+terminal.  It includes several common widgets: lists, trees, tables and tabs,
+but also more complex items such as (stacked) bar and pie charts, scatter plots,
+gauges, and even images and a canvas for drawing `high resolution' braille dots.
+
+You can also easily create new custom widgets.  Widgets can be coloured and
+styled and positioned absolutely or relatively.  They respond to keyboard,
+mouse, and terminal resizing events.")
+    (license license:expat)))
+
 (define-public go-github-com-golangplus-fmt
   (package
     (name "go-github-com-golangplus-fmt")