summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-08-10 19:43:09 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-06 01:25:30 -0400
commit701041aac1fdd74fc036c83285596aae4f47cb39 (patch)
tree56d26cb0b0d852d548a46f790e28a5e0fc12d0b7 /gnu/packages/golang.scm
parent83064e2683766b0db85d61b1c16d1462cae76657 (diff)
downloadguix-701041aac1fdd74fc036c83285596aae4f47cb39.tar.gz
gnu: Add go-github-com-dgryski-go-mph.
* gnu/packages/golang.scm (go-github-com-dgryski-go-mph): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b50da8a395..524d7ff66d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5511,6 +5511,30 @@ SysVinit, and more.")
 MetroHash}, a high quality, high performance hash algorithm.")
     (license license:expat)))
 
+(define-public go-github-com-dgryski-go-mph
+  (package
+    (name "go-github-com-dgryski-go-mph")
+    (version "0.0.0-20211217222804-81a8625fb7ed")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dgryski/go-mph")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10q8l4jdzqf54bnnxka2jk6qzayri3ijv51knn1n0iimfric8w9g"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/dgryski/go-mph"))
+    (propagated-inputs
+     (list go-github-com-dgryski-go-metro))
+    (home-page "https://github.com/dgryski/go-mph")
+    (synopsis "Go minimal perfect hash function")
+    (description
+     "This package implements a hash/displace minimal perfect hash function.")
+    (license license:expat)))
+
 (define-public go-github-com-docker-distribution
   (let ((commit "325b0804fef3a66309d962357aac3c2ce3f4d329")
         (revision "0"))