summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-21 16:31:37 -0400
committerLeo Famulari <leo@famulari.name>2016-10-21 19:13:01 -0400
commitf08add0c5a3f1f7200b0a00e17ed880692d2244b (patch)
tree1a1e7d128f0330584aebd74f7af23905fc016ac1 /gnu/packages/golang.scm
parent4b0bac4b3ee6cd674b12557f397c35fadd640496 (diff)
downloadguix-f08add0c5a3f1f7200b0a00e17ed880692d2244b.tar.gz
gnu: go-1.7: Skip test that fails due to time zone name change.
* gnu/packages/golang.scm (go-1.7)[arguments]: Skip test "TestLoadFixed" in
'prebuild' phase.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 63e2186a28..9b81f69c5d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -282,7 +282,18 @@ sequential processes (CSP) concurrent programming features added.")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")
                     ("net/lookup_test.go" "(.+)(TestLookupPort.+)")
                     ("syscall/exec_linux_test.go"
-                     "(.+)(TestCloneNEWUSERAndRemapNoRootDisableSetgroups.+)")))
+                     "(.+)(TestCloneNEWUSERAndRemapNoRootDisableSetgroups.+)")
+                    ;; This test broke when tzdata updated to 2016g:
+                    ;; https://github.com/golang/go/issues/17276
+
+                    ;; Applying the upstream patch causes the failure of another
+                    ;; test, because that test requires upstream's mtimes to be
+                    ;; preserved, but applying the patch and re-packing the
+                    ;; tarball causes mtimes to be set to Unix epoch.
+                    ;; https://github.com/golang/go/issues/17535
+
+                    ;; TODO Try re-enabling this test for Go > 1.7.3.
+                    ("time/time_test.go" "(.+)(TestLoadFixed.+)")))
 
                  (substitute* "../misc/cgo/testsanitizers/test.bash"
                    (("(CC=)cc" all var) (string-append var "gcc")))