summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 17:39:47 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:24:59 +0200
commit7601b4e4fe93130562475efc67a641c2f3b8ccc8 (patch)
tree62ff1a1858fbcd60b3a7d70f7cfb9a2beaa586f0 /gnu/packages/golang.scm
parent3291be815b3b31223fd190204e5c56ffb370c4a4 (diff)
downloadguix-7601b4e4fe93130562475efc67a641c2f3b8ccc8.tar.gz
gnu: Add go-github-com-mattn-go-colorable.
* gnu/packages/golang.scm (go-github-com-mattn-go-colorable): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 26f9fda14d..aabde78d62 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2002,3 +2002,31 @@ values.")
 tell you whether a file descriptor points to a terminal and the type of the
 terminal.")
       (license license:expat))))
+
+(define-public go-github-com-mattn-go-colorable
+  (let ((commit "efa589957cd060542a26d2dd7832fd6a6c6c3ade")
+        (revision "0"))
+    (package
+      (name "go-github-com-mattn-go-colorable")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mattn/go-colorable")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0kshi4hvm0ayrsxqxy0599iv81kryhd2fn9lwjyczpj593cq069r"))))
+      (build-system go-build-system)
+      (native-inputs
+       `(("go-github-com-mattn-go-isatty"
+          ,go-github-com-mattn-go-isatty)))
+      (arguments
+       '(#:import-path "github.com/mattn/go-colorable"))
+      (home-page "https://github.com/mattn/go-colorable")
+      (synopsis "Handle ANSI color escapes on Windows")
+      (description "This package provides @code{colorable}, a module that
+makes it possible to handle ANSI color escapes on Windows.")
+      (license license:expat))))