summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-25 20:43:23 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-07-29 16:08:33 +0200
commit7e6da91fa736bf1494e12f7bb947df42fb2fbbd1 (patch)
tree56922fd348f2a8edd543395c6215d263cb1b6e44 /gnu/packages/golang.scm
parent06c2d0e6c1f8c6d79daeb7991087b9eff388b28c (diff)
downloadguix-7e6da91fa736bf1494e12f7bb947df42fb2fbbd1.tar.gz
gnu: go-golang-org-x-text-transform: Inherit from related package.
* gnu/packages/golang.scm (go-golang-org-x-text-transform): Inherit from
go-golang-org-x-text-encoding.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 9 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b423d0419..2d59da7169 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1202,32 +1202,17 @@ encodings are provided in subpackages.")
     (license license:bsd-3)))
 
 (define-public go-golang-org-x-text-transform
-  (let ((commit "e19ae1496984b1c655b8044a65c0300a3c878dd3")
-        (revision "1"))
-    (package
-      (name "go-golang-org-x-text-transform")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://go.googlesource.com/text")
-                      (commit commit)))
-                (file-name (string-append "go.googlesource.com-text-"
-                                          version "-checkout"))
-                (sha256
-                 (base32
-                  "1cvnnx8nwx5c7gr6ajs7sldhbqh52n7h6fsa3i21l2lhx6xrsh4w"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "golang.org/x/text/transform"
-         #:unpack-path "golang.org/x/text"))
-      (synopsis "Go text transformation")
-      (description "This package provides @code{transform}, which provides
+  (package
+    (inherit go-golang-org-x-text-encoding)
+    (name "go-golang-org-x-text-transform")
+    (arguments
+     `(#:import-path "golang.org/x/text/transform"
+       #:unpack-path "golang.org/x/text"))
+    (synopsis "Go text transformation")
+    (description "This package provides @code{transform}, which provides
 reader and writer wrappers that transform the bytes passing through.  Example
 transformations provided by other packages include normalization and conversion
-between character sets.")
-      (home-page "https://go.googlesource.com/text")
-      (license license:bsd-3))))
+between character sets.")))
 
 (define-public go-golang-org-x-text-unicode-norm
   (let ((commit "e19ae1496984b1c655b8044a65c0300a3c878dd3")