summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:04:46 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:22 +0200
commit386bd7ba393297f440c198eb6d5611ff8c73d875 (patch)
tree38761f511dee28b72d5ed393f3cc0869b5cb4510 /gnu/packages/golang.scm
parent48a279ee14ac5a285185168f72041418550371fa (diff)
downloadguix-386bd7ba393297f440c198eb6d5611ff8c73d875.tar.gz
gnu: Add go-github-com-libp2p-go-flow-metrics.
* gnu/packages/golang.scm (go-github-com-libp2p-go-flow-metrics): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a9bb4e68d1..6c8754b97c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2564,3 +2564,31 @@ generation features.  This code generation is used to achieve:
       (synopsis "XXX")
       (description "XXX")
       (license license:expat))))
+
+(define-public go-github-com-libp2p-go-flow-metrics
+  (let ((commit "7e5a55af485341567f98d6847a373eb5ddcdcd43")
+        (revision "0"))
+    (package
+      (name "go-github-com-libp2p-go-flow-metrics")
+      (version (git-version "0.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/libp2p/go-flow-metrics.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1p87iyk6q6f3g3xkncssx400qlld8f2z93qiz8m1f97grfyhjif1"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/libp2p/go-flow-metrics"
+         ;; TODO: Tests hang.
+         #:tests? #f))
+      (home-page
+       "https://github.com/libp2p/go-flow-metrics")
+      (synopsis "Simple library for tracking flow metrics")
+      (description "A simple alternative to rcrowley's @command{go-metrics}
+that's a lot faster (and only does simple bandwidth metrics).")
+      (license license:expat))))