summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:45:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:45:33 +0100
commit1d948dbd97e93dec92dd486efbb8075271f3fde9 (patch)
tree13357700fe29b3be4babee602083f4e145921df5 /gnu/packages/golang.scm
parent72274434a8419d80d036b9e91af50a291cda644c (diff)
downloadguix-1d948dbd97e93dec92dd486efbb8075271f3fde9.tar.gz
gnu: Add go-github-com-valyala-bytebufferpool.
* gnu/packages/golang.scm (go-github-com-valyala-bytebufferpool): New
variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 23e36af998..cf6e60aace 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8906,6 +8906,29 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
      "Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
     (license license:expat)))
 
+(define-public go-github-com-valyala-bytebufferpool
+  (package
+    (name "go-github-com-valyala-bytebufferpool")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/valyala/bytebufferpool")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "01lqzjddq6kz9v41nkky7wbgk7f1cw036sa7ldz10d82g5klzl93"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/valyala/bytebufferpool"))
+    (home-page "https://github.com/valyala/bytebufferpool")
+    (synopsis "Anti-memory-waste byte buffer pool for Golang")
+    (description
+     "@code{bytebufferpool} implements a pool of byte buffers with
+anti-fragmentation protection.")
+    (license license:expat)))
+
 (define-public go-github-com-vmihailenco-msgpack-v4
   (package
     (name "go-github-com-vmihailenco-msgpack-v4")