summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-21 01:18:29 -0400
committerLeo Famulari <leo@famulari.name>2017-03-21 01:30:39 -0400
commitf826c8c7ee2634acfff1a04f60787d6b02672c36 (patch)
treeaa9428cdfff56b87206d3bd966438be7a786fe39 /gnu/packages/golang.scm
parentdeee8a9dfcd86e3f97035f2d71e34dfadbc09397 (diff)
downloadguix-f826c8c7ee2634acfff1a04f60787d6b02672c36.tar.gz
gnu: go@1.4, go@1.7: Skip test that fails with tzdata-2017a.
* gnu/packages/golang.scm (go-1.4, go-1.7)[arguments]: Disable the test
TestParseInLocation in 'prebuild' phase.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4bb54f031d..00630ce067 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -120,6 +120,7 @@
                   ;; https://github.com/golang/go/issues/17545
                   ;; https://github.com/golang/go/issues/17276
                   ("time/time_test.go" "(.+)(TestLoadFixed.+)")
+                  ("time/format_test.go" "(.+)(TestParseInLocation.+)")
 
                   ("os/exec/exec_test.go" "(.+)(TestEcho.+)")
                   ("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
@@ -266,6 +267,7 @@ sequential processes (CSP) concurrent programming features added.")
                     ("net/dial_test.go" "(.+)(TestDialTimeout.+)")
                     ("os/os_test.go" "(.+)(TestHostname.+)")
                     ("time/format_test.go" "(.+)(TestParseInSydney.+)")
+                    ("time/format_test.go" "(.+)(TestParseInLocation.+)")
                     ("os/exec/exec_test.go" "(.+)(TestEcho.+)")
                     ("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
                     ("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")