summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-09-19 16:32:13 -0700
committerLeo Famulari <leo@famulari.name>2021-12-08 13:35:34 -0500
commit8ac2d303e4e01fb5a5b22e7fd78f174e0a931afd (patch)
tree4305e6099cc9b256138c35da63abd919a61d794f /gnu/packages/golang.scm
parent93c7a5103d240dfc5ba4b39969faf198e7a350fa (diff)
downloadguix-8ac2d303e4e01fb5a5b22e7fd78f174e0a931afd.tar.gz
gnu: go-github-com-alcortesm-tgz: Don't reset gzip timestamps.
The tgz files are committed test fixtures, so don't reset their timestamps.

* gnu/packages/golang.scm (go-github-com-alcortesm-tgz)[arguments]:
Remove 'make-git-checkout-writable' phase.  Delete 'reset-gzip-timestamps' phase
instead.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6d81bdba1..d555a92579 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7622,11 +7622,8 @@ ssh-agent process using the sample server. ")
        `(#:import-path "github.com/alcortesm/tgz"
          #:phases
          (modify-phases %standard-phases
-           (add-after 'unpack 'make-git-checkout-writable
-             (lambda* (#:key outputs #:allow-other-keys)
-               (for-each make-file-writable (find-files "."))
-               (for-each make-file-writable (find-files (assoc-ref outputs "out")))
-               #t)))))
+           ;; Files are test fixtures, not generated.
+           (delete 'reset-gzip-timestamps))))
       (home-page "https://github.com/alcortesm/tgz/")
       (synopsis "Go library to extract tgz files to temporal directories")
       (description "This package provides a Go library to extract tgz files to