summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:07 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-20 08:54:11 -0500
commit4fb0b075e4c4fe50ed097dad38861de5b930162f (patch)
treed86ab2a9a3f21f1888246954b0bd4dfe95ff6025 /gnu/packages/golang.scm
parenta2af6352e3bb4c009dcd16d596586c804fcf79be (diff)
downloadguix-4fb0b075e4c4fe50ed097dad38861de5b930162f.tar.gz
gnu: Add go-github-com-gogs-chardet.
* gnu/packages/golang.scm (go-github-com-gogs-chardet): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 89feb19846..58f8a8996f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10637,6 +10637,29 @@ Specification.")
 array or reader.")
     (license license:expat)))
 
+(define-public go-github-com-gogs-chardet
+  (package
+    (name "go-github-com-gogs-chardet")
+    (version "0.0.0-20211120154057-b7413eaefb8f")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gogs/chardet")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12j8q5wc9m4n51v2j2m40nahqdl9bh3hzpdp26clzq91kc2amiz0"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/gogs/chardet"))
+    (home-page "https://github.com/gogs/chardet")
+    (synopsis "Character set detection for Go")
+    (description
+     "The chardet package ports character set detection from
+ICU to Go.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar