summary refs log tree commit diff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/gpodder.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm57
1 files changed, 24 insertions, 33 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 0c8f1cf50d..8df7c0c22b 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -62,26 +62,26 @@
        (patches (search-patches "gpodder-disable-updater.patch"))))
     (build-system python-build-system)
     (native-inputs
-     `(("intltool" ,intltool)
-       ("python-coverage" ,python-coverage)
-       ("python-minimock" ,python-minimock)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-cov" ,python-pytest-cov)
-       ("python-pytest-httpserver" ,python-pytest-httpserver)
-       ("which" ,which)))
+     (list intltool
+           python-coverage
+           python-minimock
+           python-pytest
+           python-pytest-cov
+           python-pytest-httpserver
+           which))
     (inputs
-     `(("bash-minimal" ,bash-minimal)
-       ("gtk+" ,gtk+)
-       ("python-pygobject" ,python-pygobject)
-       ("python-pycairo" ,python-pycairo)
-       ("python-requests" ,python-requests)
-       ("python-dbus" ,python-dbus)
-       ("python-html5lib" ,python-html5lib)
-       ("python-mutagen" ,python-mutagen)
-       ("python-mygpoclient" ,python-mygpoclient)
-       ("python-podcastparser" ,python-podcastparser)
-       ("youtube-dl" ,youtube-dl)
-       ("xdg-utils" ,xdg-utils)))
+     (list bash-minimal
+           gtk+
+           python-pygobject
+           python-pycairo
+           python-requests
+           python-dbus
+           python-html5lib
+           python-mutagen
+           python-mygpoclient
+           python-podcastparser
+           youtube-dl
+           xdg-utils))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -144,7 +144,7 @@ locally for later listening.")
                                        "libmygpo-qt-missing-qt5-modules.patch"))))
     (build-system cmake-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     (list pkg-config))
     (inputs
      `(("qt" ,qtbase-5)))
     (arguments
@@ -172,9 +172,7 @@ and track podcasts.")
          "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-coverage" ,python-coverage)
-       ("python-minimock" ,python-minimock)
-       ("python-nose" ,python-nose)))
+     (list python-coverage python-minimock python-nose))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -200,7 +198,7 @@ downloading episode status changes.")
        (sha256
         (base32 "0m24r2qhck0win44xfhxajbppkss4ha6am0042s0xyq3408883m3"))))
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     (list python-pytest))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -230,15 +228,8 @@ in Python.")
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)
-       ("ronn-ng" ,ronn-ng)))
-    (inputs `(("curl" ,curl)
-              ("glib" ,glib)
-              ("id3lib" ,id3lib)
-              ("libxml2" ,libxml2)))
+     (list autoconf automake libtool pkg-config ronn-ng))
+    (inputs (list curl glib id3lib libxml2))
     (synopsis "Command line podcast downloader")
     (description
      "castget is a simple, command-line based RSS enclosure downloader.  It is