summary refs log tree commit diff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-04-15 18:41:02 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-17 13:03:02 +0200
commit5ea902874bff728770a46002be4b3a749d1ee8db (patch)
tree6a3c9a96e1d12eed8b2b3dc3bb3fa1f85f80be7d /gnu/packages/gpodder.scm
parent54e3eb06ca9cca189ab0cb9b9c191a156e68d659 (diff)
downloadguix-5ea902874bff728770a46002be4b3a749d1ee8db.tar.gz
gnu: gpodder: Run tests.
* gnu/packages/gpodder.scm (gpodder)[native-inputs]: Add python-coverage and
python-minimock.
[arguments]: Replace the 'check phase and invoke "make unittest".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 84c63ce806..98d7a84ce7 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -51,7 +51,9 @@
        (file-name (git-file-name name version))))
     (build-system python-build-system)
     (native-inputs
-     `(("intltool" ,intltool)))
+     `(("intltool" ,intltool)
+       ("python-coverage" ,python-coverage)
+       ("python-minimock" ,python-minimock)))
     (inputs
      `(("gtk+" ,gtk+)
        ("python-pygobject" ,python-pygobject)
@@ -72,6 +74,12 @@
                (substitute* "src/gpodder/util.py"
                  (("xdg-open") (string-append xdg-utils "/bin/xdg-open")))
                #t)))
+         (replace 'check
+           (lambda _
+             ; The `unittest' target overrides the PYTHONPATH variable.
+             (substitute* "makefile"
+               (("PYTHONPATH=src/") "PYTHONPATH=${PYTHONPATH}:src/"))
+             (invoke "make" "unittest")))
          ;; 'msgmerge' introduces non-determinism by resetting the
          ;; POT-Creation-Date in .po files.
          (add-before 'install 'do-not-run-msgmerge