summary refs log tree commit diff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 16:41:25 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:11 +0100
commite48eac3b3ed0a29dbcf87cd22106354f50494751 (patch)
tree3dec269b8b35daf174df6af113337831feb4d480 /gnu/packages/gpodder.scm
parent808fc71e7c127766d057d099e728464d98e84706 (diff)
downloadguix-e48eac3b3ed0a29dbcf87cd22106354f50494751.tar.gz
gnu: python-podcastparser: Update to 0.6.6.
* gnu/packages/gpodder.scm (python-podcastparser): Update to 0.6.6.
[native-inputs, arguments]: Substitute python-pytest for python-coverage
& python-nose.
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 26ea15ba56..fc3a78bc7b 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -177,21 +177,20 @@ downloading episode status changes.")
 (define-public python-podcastparser
   (package
     (name "python-podcastparser")
-    (version "0.6.5")
+    (version "0.6.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "podcastparser" version))
        (sha256
-        (base32 "0k62ppg20i41gcc5x8ddjn7zbpy47hqpxzrq9257g2c71m4qw07b"))))
+        (base32 "0m24r2qhck0win44xfhxajbppkss4ha6am0042s0xyq3408883m3"))))
     (native-inputs
-     `(("python-coverage" ,python-coverage)
-       ("python-nose" ,python-nose)))
+     `(("python-pytest" ,python-pytest)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (invoke "nosetests"))))))
+           (lambda _ (invoke "pytest"))))))
     (build-system python-build-system)
     (home-page "http://gpodder.org/podcastparser")
     (synopsis "Simplified and fast RSS parser Python library")