summary refs log tree commit diff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-13 11:03:46 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-13 13:00:37 +0200
commited8a551653e3d833d3c9cbbd412782acfb26f666 (patch)
tree6e10ad3a54cb0d269889111a1443777caea1648f /gnu/packages/gps.scm
parent286ef5d97c2054c4361f728d2c92587084262e46 (diff)
downloadguix-ed8a551653e3d833d3c9cbbd412782acfb26f666.tar.gz
gnu: gpxsee: Fetch from Git instead of a generated tarball.
* gnu/packages/gps.scm (gpxsee)[source]: Use 'git-fetch'.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index ec45704029..75212ed60e 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -177,14 +177,14 @@ coordinates as well as partial support for adjustments in global coordinate syst
     (name "gpxsee")
     (version "7.8")
     (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://github.com/tumic0/GPXSee/archive/"
-                              version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tumic0/GPXSee")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1k9nbs3knl6s0s4bf1rgrc9lwczawnzm7629igw0zmxb5yka7d9v"))))
+                "1ymqz4wrl9ghkyyqi2vrnlyvz3fc84s3p8a1dkiqlvyvj360ck9j"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases