summary refs log tree commit diff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-01-05 22:54:17 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-01-06 11:14:53 +0200
commitf024a7ba604fb18721a056e65777ae969d8b9681 (patch)
treec84f505f3f0c08b9ea0755606f28957bbafd3c4c /gnu/packages/gps.scm
parent684d27c36fcb2cc911a0b77685b27d8839317ee7 (diff)
downloadguix-f024a7ba604fb18721a056e65777ae969d8b9681.tar.gz
gnu: gpsbabel: Update to 1.7.0.
* gnu/packages/gps.scm (gpsbabel): Update to 1.7.0.
[source]: Use git-fetch, remove obsolete patches.
[inputs]: Add libusb.
* gnu/packages/patches/gpsbabel-minizip.patch: Remove file.
* gnu/packages/patches/gpsbabel-qstring.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove entries.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index e0f489f8de..fdb64f0902 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -51,21 +52,18 @@
 (define-public gpsbabel
   (package
     (name "gpsbabel")
-    (version "1.5.4")
+    (version "1.7.0")
     (source (origin
-              (method url-fetch)
-              ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
-              ;; get it from elsewhere.
-              (uri (string-append
-                    "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
-                    version ".orig.tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gpsbabel/gpsbabel")
+                    (commit (string-append
+                             "gpsbabel_"
+                             (string-replace-substring version "." "_")))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "19hykxhyl567gf8qcrl33qhv95w0g4vxw9r3h9b8d8plx9bnaf8l"))
-              (patches (search-patches
-                        "gpsbabel-minizip.patch"
-                        ;; XXX: Remove this patch on the next release.
-                        "gpsbabel-qstring.patch"))
+                "010g0vd2f5knpq5p7qfnl31kv3r8m5sjdsafcinbj5gh02j2nzpy"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -87,8 +85,9 @@
        #:tests? #f))
     (inputs
      `(("expat" ,expat)
-       ("zlib" ,zlib)
-       ("qtbase" ,qtbase)))
+       ("libusb" ,libusb)
+       ("qtbase" ,qtbase)
+       ("zlib" ,zlib)))
     (native-inputs
      `(("which" ,which)
        ("qttools" ,qttools)