summary refs log tree commit diff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-29 18:51:43 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-30 14:08:03 +0100
commit82350397ed4340e84e54ed73db5568960b72f872 (patch)
tree2bd7b05e890ba159293f62ed8d573e02e42c2517 /gnu/packages/gps.scm
parente9a6d2252c5d35f7c22474280547f94461121265 (diff)
downloadguix-82350397ed4340e84e54ed73db5568960b72f872.tar.gz
gnu: gpsbabel: Disable tests on i686.
* gnu/packages/gps.scm (gpsbabel)[arguments]: Add #:tests?.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 1b85a16980..a6ed39e9dc 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -47,13 +47,18 @@
                 "1pd01kra9l5ihy1by87qia0mpbpcif7g5yg7r9z2bnw7711jm3yb"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags '("--with-zlib=system")
+     `(#:configure-flags '("--with-zlib=system")
        #:phases (alist-cons-before
                  'configure 'pre-configure
                  (lambda _
                    (chdir "gpsbabel"))
                  ;; TODO: "make doc" requires Docbook & co.
-                 %standard-phases)))
+                 %standard-phases)
+
+       ;; On i686, 'raymarine.test' fails because of a rounding error:
+       ;; <http://hydra.gnu.org/build/133040>.  As a workaround, disable tests
+       ;; on these platforms.
+       #:tests? (not (string-prefix? "i686" (%current-system)))))
     (inputs
      `(("expat" ,expat)
        ("zlib" ,zlib)