summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-18 01:15:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-18 01:15:57 -0500
commit5f110be22075402059ed7177b8f1839c9de6421b (patch)
treee62ea68ad0f6437a46b26832621a9258f20db0b9 /gnu/packages/graph.scm
parent1ebc9e88234812f6e6d00694ed7d27ac2ac4dc05 (diff)
downloadguix-5f110be22075402059ed7177b8f1839c9de6421b.tar.gz
gnu: igraph: Update to 0.9.6.
* gnu/packages/graph.scm (igraph): Update to 0.9.6.
[snippet]: Simplify source snippet a bit, leveraging the new support for
using an external plfit library.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 8810617795..5682c4ecdc 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -89,7 +89,7 @@ distributions in empirical data.  SIAM Review 51, 661-703 (2009)}).")
 (define-public igraph
   (package
     (name "igraph")
-    (version "0.9.5")
+    (version "0.9.6")
     (source
      (origin
        (method url-fetch)
@@ -103,27 +103,18 @@ distributions in empirical data.  SIAM Review 51, 661-703 (2009)}).")
                    (substitute* "CMakeLists.txt"
                      (("add_subdirectory\\(vendor\\).*")
                       ""))
-                   (substitute* "src/CMakeLists.txt"
+                   ;; Help CMake to find our plfit headers.
+                   (substitute* "etc/cmake/FindPLFIT.cmake"
+                     (("^  NAMES plfit.h.*" all)
+                      (string-append all
+                                     "  PATH_SUFFIXES plfit")))
+                   (substitute* '("src/CMakeLists.txt"
+                                  "etc/cmake/benchmark_helpers.cmake")
                      ;; Remove bundling related variables.
-                     ((".*_IS_VENDORED.*") "")
-                     ;; Remove link/install directives to bundled plfit.
-                     (("plfit") "")
-                     ;; Patch in support to find plfit from the system.
-                     (("# Link igraph statically to some.*" all)
-                      (string-append "\
-find_package(PkgConfig REQUIRED)
-pkg_check_modules(PLFIT REQUIRED libplfit IMPORTED_TARGET)
-target_link_libraries(igraph PUBLIC PkgConfig::PLFIT)\n"
-                                     all)))
-                   (substitute* (find-files "." "(\\.h|\\.c)$")
-                     ;; Adjust includes for the newer plfit used.
-                     (("plfit/error.h")
-                      "plfit/plfit_error.h")
-                     ;; And the newer SuiteSparse.
-                     (("cs/cs.h")
-                      "cs.h"))))
+                     ((".*_IS_VENDORED.*")
+                      ""))))
        (sha256
-        (base32 "0ym1jnj6rqrrjad0dk7jsrm9351zdd0654brbn38gqp1j9wgdqy4"))))
+        (base32 "11zkj9bpqcadb0rc4ahvjp9047dp9hna8cn3b0vl3zpc9v2rwabw"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))