summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-17 00:11:44 +0100
committerMarius Bakke <marius@gnu.org>2021-12-17 19:07:17 +0100
commita133a0288c7808e9f28c9c64c9ce4ae146ceba04 (patch)
tree0dade5eae29ec2224c59b73019d2fd2aaa370ef6 /gnu/packages/graph.scm
parent1d505c05bd0da72e1db91cef8e9bb5732a42631a (diff)
downloadguix-a133a0288c7808e9f28c9c64c9ce4ae146ceba04.tar.gz
gnu: python-graph-tool: Remove input labels.
* gnu/packages/graph.scm (python-graph-tool)[arguments]: Import SITE-PACKAGES
from (guix build python-build-system), and use instead of homegrown procedure.
[native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index ac40996f38..084fdf8c90 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -540,30 +540,26 @@ transformed into common image formats for display or printing.")
                 "0v58in4rwk9fhjarjw6xfxpx5zz2z13sy3yvd14b5kr0884yw6sz"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
+     `(#:imported-modules (,@%gnu-build-system-modules
+                           (guix build python-build-system))
+       #:modules (,@%gnu-build-system-modules
+                  ((guix build python-build-system) #:select (site-packages)))
+       #:configure-flags
        (list (string-append "--with-boost="
                             (assoc-ref %build-inputs "boost"))
              (string-append "--with-python-module-path="
-                            (assoc-ref %outputs "out")
-                            "/lib/python"
-                            ,(version-major+minor
-                              (package-version
-                               (car (assoc-ref
-                                     (package-inputs this-package)
-                                     "python"))))
-                            "/site-packages/"))))
+                            (site-packages %build-inputs %outputs)))))
     (native-inputs
-     `(("ncurses" ,ncurses)
-       ("pkg-config" ,pkg-config)))
+     (list ncurses pkg-config))
     (inputs
-     `(("boost" ,boost)
-       ("cairomm" ,cairomm-1.14)
-       ("cgal" ,cgal)
-       ("expat" ,expat)
-       ("gmp" ,gmp)
-       ("gtk+" ,gtk+)
-       ("python" ,python-wrapper)
-       ("sparsehash" ,sparsehash)))
+     (list boost
+           cairomm-1.14
+           cgal
+           expat
+           gmp
+           gtk+
+           python-wrapper
+           sparsehash))
     (propagated-inputs
      (list python-matplotlib python-numpy python-pycairo python-scipy))
     (synopsis "Manipulate and analyze graphs with Python efficiently")